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Installing KNIME Analytics Platform


For step-by-step videos on how to install KNIME Analytics Platform, please take

a look at our KNIMETV YouTube channel.

1. Go to the download page on the KNIME.com website to start installing KNIME Analytics

Platform.

2. The download page shows three tabs which can be opened individually:

◦ Register for Help and Updates: here you can optionally provide some personal

information and sign up to our mailing list to receive the latest KNIME news

◦ Download KNIME: this is where you can download the software

◦ Getting Started: this tab gives you information and links about what you can do

after you have installed KNIME Analytics Platform

3. Now open the Download KNIME tab and click the installation option that fits your

operating system. KNIME Analytics Platform can be installed on Windows, Linux, or

macOS.

Notes on the different options for Windows:

◦ The Windows installer extracts the compressed installation folder, adds an icon to

your desktop, and suggests suitable memory settings.

◦ The self-extracting archive simply creates a folder containing the KNIME

installation files. You don’t need any software to manage archiving.

◦ The zip archive can be downloaded, saved, and extracted in your preferred

location on a system to which you have full access rights.
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Figure 1. KNIME Analytics Platform versions

4. Read and accept the privacy policy and terms and conditions. Then click Download.

5. Once downloaded, proceed with installing KNIME Analytics Platform:

◦ Windows: Run the downloaded installer or self-extracting archive. If you have

chosen to download the zip archive instead, unpack it to a location of your choice.

Run knime.exe to start KNIME Analytics Platform.

◦ Linux: Extract the downloaded tarball to a location of your choice. Run the knime

executable to start KNIME Analytics Platform.

◦ Mac: Double click the downloaded dmg file and wait for the verification to finish.

Then move the KNIME icon to Applications. Double click the KNIME icon in the list

of applications to launch KNIME Analytics Platform.

 Also check the KNIME Getting Started Guide and the KNIME Workbench Guide.

Configuration settings and knime.ini file

When installing KNIME Analytics Platform, configuration settings are set to their defaults,

and they can later be changed in the knime.ini file. The configuration settings, i.e. options

used by the Java Virtual Machine when KNIME Analytics Platform is launched, range from

memory settings to system properties required by some extensions.

You can find knime.ini in the installation folder of KNIME Analytics Platform.
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

On MacOS: To locate knime.ini on MacOS, open Finder and navigate to your

installed Applications. Next, right click the KNIME application, select Show

Package Contents in the menu, and navigate to Contents → Eclipse.

The knime.ini file can be edited with any plaintext editor, such as Notepad (Windows),

TextEdit (MacOS) or gedit (Linux).

Allocating memory in knime.ini file

The entry -Xmx1024m in the knime.ini file specifies how much memory KNIME Analytics

Platform is allowed to use. The setting for this value will depend on how much memory is

available in your machine. KNIME recommends setting it to approximately one half of your

available memory, but you can modify the value based on your needs. For example, if your

computer has 16 GB of memory, you might set the entry to -Xmx8192m.
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Installing Extensions and Integrations

If you want to add capabilities to KNIME Analytics Platform, you can install extensions and

integrations. The available extensions range from free open source extensions and

integrations provided by KNIME to free extensions contributed by the community and

commercial extensions including novel technology nodes provided by our partners.

The KNIME extensions and integrations developed and maintained by KNIME contain deep

learning algorithms provided by Keras, high performance machine learning provided by H2O,

big data processing provided by Apache Spark, and scripting provided by Python and R, just

to mention a few.

Install extensions from:

• KNIME Hub:

◦ Search for the Extension or Integration you want to install in the search bar

◦ Click Extensions on the results page

◦ Click the extension you want to install, and from the extension page and drag and

drop the squared yellow icon, shown in Figure 2, to the workbench of KNIME

Analytics Platform. A window will open asking if you want to search and install

the extension or integration. Click Yes and follow the instructions.

Figure 2. Install the KNIME Integrated Deployment Extension from KNIME Hub

◦ Restart KNIME Analytics Platform.

• KNIME Analytics Platform:

◦ Click File on the menu bar and then Install KNIME Extensions…. The dialog shown

in Figure 3 opens.
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Figure 3. Installing Extensions and Integrations from KNIME Analytics Platform

◦ Select the extensions you want to install

◦ Click Next and follow the instructions

◦ Restart KNIME Analytics Platform.

The Install KNIME Extensions menu provides the extensions that are available via the update

sites you have enabled.


For more information, take a look at our video on How to Install Extensions in

KNIME Analytics Platform. Also see the Extensions and Integrations Guide.

To uninstall an extension, click Help, About KNIME Analytics Platform, and then Installation

Details. A dialog shown in Figure 4 opens. Now, select the extension that you want to

uninstall, and click Uninstall….
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Figure 4. Uninstalling Extensions and Integrations
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Updating KNIME Analytics Platform and
Extensions

It is good to make sure that you always use the latest version of KNIME Analytics Platform

and its extensions.

Do this by:

1. Clicking File → Update KNIME…. In the dialog that opens, select the available updates

you want to install and then click Next.

2. Proceed by following the instructions. KNIME Analytics Platform has to be restarted in

order to apply the updates.
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Update Sites

The Update Sites are where KNIME retrieves additional software in the form of extensions as

well as updates. To see or edit the available update sites, select File → Preferences →
Install/Update → Available Software Sites.

Default Update Sites

These four updates sites are provided by KNIME and are always available:

Figure 5. Available Update Sites

KNIME Analytics Platform 4.5 Update

Site: Provides all extensions and

integrations maintained by KNIME: R,

Python, H2O Machine Learning, Apache

Spark for big data, and many more.

Contains KNIME Labs Extensions, which

are extensions that are not yet part of the

set of stable KNIME extensions because

their functionality may not yet be

finalized.

KNIME Community Extensions (Trusted):

Provides trusted community extensions,

i.e. extensions created by the KNIME

community, which have been tested for

backward compatibility and compliance

with KNIME quality standards.

KNIME Partner Extensions: Provides

extensions created by KNIME partners.

Community Extensions (Experimental):

Provides additional extensions created by

the KNIME community.

KNIME Analytics Platform 4.5 Update Site and KNIME Community Extensions (Trusted) are

enabled by default.

KNIME Analytics Platform Installation Guide

© 2020 KNIME AG. All rights reserved. 8



Adding External Update Sites

To install extensions that are not part of the above update sites, click Add to manually add

the relevant update site, inserting the Name and Location as shown in Figure 6.

Figure 6. Add Update Sites

After adding a new update site you will see it listed in the Available Software Sites. You must

now enable it by selecting it from the list.

Adding Local Update Sites

If your working environment has limited internet access or you receive an error message

“Proxy Authentication Required” when connecting to a remote update site (provided by a

URL), you can install extensions from a local zip file.

1. Download KNIME update sites as zip files at the following links:

◦ KNIME Analytics Platform Update Site

◦ KNIME Community Extensions

◦ KNIME Partner Extensions

2. Save the zip file containing the extensions to your local system

3. Select File → Preferences → Install/Update → Available Software Sites and enter the

path to the zip file by clicking Add → Archive… as shown in Figure 7.
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Figure 7. Adding Update Sites from Zip Archive


If the same extensions are provided by a URL, you will first have to disable

the update site by disabling it in the list.

4. Now click Apply and Close



If the same extensions are also provided by a remote update site, you will

first have to disable that update site by deselecting its entry in the

Available Software Sites dialog and confirming via Apply and Close.
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Working with the Nightly Builds

Once a night, a new version of KNIME Analytics Platform is created directly from our

development branch. The Nightly Build versions available here provide insight into what’s

coming up in the next regular release. However, for real work, always use a version of a

standard KNIME release. Also read the following disclaimer before proceeding:



Really, really, really important disclaimer

This is most definitely not production quality code. These nightly builds are

what we use internally to validate and test recent developments, so they are not

tested as thoroughly as standard KNIME releases. Furthermore new nodes or

functionality may change substantially (or disappear entirely) from one build to

the next. It’s even possible that workflows you edit or create with nightly builds

stop being readable by future (or past) versions…

These nightlies are a great way to get a sneak peek at what may be coming in

the next version of KNIME and provide feedback and suggestions. They are not

a particularly safe way to do real work.
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Changelog (KNIME Analytics Platform 4.5)

Detailed changelog for v4.5.x releases

KNIME Analytics Platform 4.5.0

(see highlights summary)

Release date: December 06, 2021

New nodes

• AP-17909: Python Script (Labs) ("zero copy" data exchange giving significant

performance improvements)

• AP-17836: Workflow Service: New nodes to build and call (remote) workflows, incl.

support for dynamic and large data (Labs)

• AP-17834: Set Files/Folders Permissions

• AP-17829: MongoDB Run Command

• AP-17806: KNIME Mountpoint Connector

• AP-17540: MongoDB Aggregation node

• AP-17433: KNIME Workflow Data Area Connector

• AP-17316: SharePoint Online List Reader

• AP-17239: Local File System Connector

• AP-16826: Binary Object to Model and Model to Binary Object nodes

• AP-16621: Excel Cell Updater

• AP-11960: Parameter Optimization Loop Start with table input

• AP-8824: Generic S3 Connector

Enhancements

• AP-18048: "Column Backend" table storage format moved out of KNIME Labs (ready for

production use)

• AP-17833: Add option to read POSIX attributes to Files/Folders Meta Info node

• AP-17675: Support code completion in MongoDB nodes
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• AP-17674: Support bulk execution in MongoDB for better performance

• AP-17661: Support Azure AD login in Snowflake Connector

• AP-17660: Support Azure AD login in MS SQL Server Connector

• AP-17525: WEKA models should not be kept in memory

• AP-17513: Support Kerberos authentication in PostgreSQL Connector node

• AP-17478: Add node decorator for single selection widgets with active re-execution

setting

• AP-17477: Configure re-execution in single selection widget node

• AP-17475: Feature Request: Add "Reply to" field in Send Email node

• AP-17419: Support database connection initialization statement on KNIME Server

• AP-17418: JDBC parameter type DELEGATED_GSS_CREDENTIAL to support Kerberos

constrained delegation for Microsoft SQL Server

• AP-17229: Deprecation of "Pipeline Pilot Connector" (users instructed to consume

Pipeline Pilot’s REST API)

• AP-17223: Recursive Loop Start and End Node to support dynamic ports

• AP-17216: Power BI: Improve error message in dialog if the authentication is not

working

• AP-17194: Add dynamic port support to Counting Loop Start, Interval Loop Start and

Generic Loop Start nodes

• AP-17030: Numeric Scorer: add adjusted R Square

• AP-17028: Cleanup Views available in the AP

• AP-16719: Support Java-based constrained delegation in DB Connector nodes

• AP-16552: Configure re-execution in widgets with clear defined action

• AP-16205: REST nodes: Additional column with error cause

• AP-16150: Support more recent Python version(s)

• AP-16136: Sunburst Chart with Option to show Tool tip text

• AP-15801: Platform-aware fuzzy logic / heuristics for Conda Env Prop node

• AP-15647: Option to check for missing values in a DB WHERE clause

• AP-15563: Store time zone with component/metanode template

• AP-15521: Case Switch (replacing old "Case Switch (…)" nodes, now with dynamic

ports)

• AP-14911: Add option to append rows to an existing sheet in Excel Writer
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• AP-14631: Add option to update/remove links on linked components/metanodes in

captured Workflow Segments

• AP-14354: Add dynamic port support to Loop End and Variable Condition Loop End

nodes

• AP-14254: Microsoft SQL Server driver updated to version 9.4.0

• AP-13000: Pattern Filter Panel with option to exclude items that match the pattern

• AP-12028: Redshift support for DB Loader

• AP-11612: Table Editor (JavaScript): Support dropdown selection for string columns

• AP-11442: Add Kerberos authentication support to REST Client Nodes (GET, POST, …)

• BD-1139: (Big Data Extensions): Add support for new type annotations in Parquet

Reader

• BD-1136: (Big Data Extensions): Support legacy LIST format in Parquet Reader

Bug Fixes

• AP-18005: Workflow Executor does not apply new port configuration when configured

in executed/green state

• AP-17990: Azure Blob Storage Connection does not allow listing/browsing container

root despite SAS token permission

• AP-17970: Threads for shuffling the training data have no NodeContext

• AP-17969: Python Serializers create tables in threads without NodeContext

• AP-17949: AbstractDataInputDelegator does not fulfill InputStream#read(byte[],int,int)

contract

• AP-17907: UpdatedColumnarValueSchema doesn’t preserve table spec name

• AP-17906: Index Query node (knime-lucene) doesn’t catch DuplicateKeyException on

BufferedDataContainer#close

• AP-17905: SHAP and Shapley Values Loop fail because of already closed resources

• AP-17861: Document Parsers don’t support KNIME URLs

• AP-17841: Class Cast exception when materializing Table for Python3

• AP-17817: Re-execution does not show error although workflow execution failed

• AP-17795: "Regression Tree" appears twice in any port type selector (one is deprecated

and should be hidden)

• AP-17790: NPE when releasing MappedByteBuffer
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• AP-17730: External XML entity injection in workflow.knime files (CVE-2021-45096)

• AP-17728: IllegalArgumentException in Testworkflows

• AP-17725: Unnecessary call exceptions spam log

• AP-17724: Error when attempting to close open closeable

• AP-17710: Memory leak with Fast Tables and "Add Empty Rows"

• AP-17687: MongoDB manipulation nodes do not check column name in configure

• AP-17662: Memory leak in Voting Loop End causes hanging workflows

• AP-17646: Polynomial Regression Learner: Multiple R-Squared is incorrect

• AP-17638: Division by zero when creating cursor of empty

AbstractColumnarContainerTable

• AP-17565: NER Tag set lacks PERCENT tag value

• AP-17541: Wait… node should not block a worker thread from the thread pool when

waiting for file

• AP-17480: R conda environment: Handle different capitalization of PATH on Windows

• AP-17473: Text Output node throws NPE for string flow variables with null value

• AP-17274: Division by zero leads to "NaN" in the scorer

• AP-17222: “Interval Loop Start” can cause infinite loops due to floating point precision

problems

• AP-17177: Suboptimal estimation of default thread count (#cores + 2) — new default to

be 3 / 2 * #cores

• AP-17163: Allow leaving R preference page with invalid R home

• AP-17103: Component could not be updated if name contains a special character

• AP-16879: Error when opening views (most likely CEF only)

• AP-16545: String Manipulation logic breaks if KNIME open too long

• AP-16374: Deep learning still relying on long-deprecated

pandas.DataFrame.convert_objects method

• AP-16134: Donut Chart shows title in the middle with weird default color

• AP-15908: Keybinding conflicts when starting KNIME AP

• AP-14994: Relative to current mountpoint/workflow and should allow to

delete/copy/move workflows within the mountpoint

• AP-13895: Python model size is limited by serializer buffer size

• AP-13838: Workflow temp directory deleted while workflow is running
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• BD-1149: (Big Data Extensions): Hive Loader should fail with a human readable error

message if the file system connection is not supported

KNIME Analytics Platform 4.5.1

Release date: January 19, 2022

Enhancements

• AP-18049: Add support to Column Expressions for creating standard file system paths

Bug Fixes

• AP-18252: Bundled Chromium Browser cannot show interactive view of Composite

Views in AP

• AP-18190: Incorrect handling of spaces in UNC paths (windows)

• AP-18153: Deprecated Table Reader and File Reader nodes should not have dots for

dynamic input ports

• AP-18139: Creation of DeepLearning Environment (on preferences page) fails in 4.5.0

• AP-18100: Generic Web Services Client fails on certain WSDLs with the 4.4 update

• BD-1154: (Big Data Extensions): Metadata browsing fails with Local Big Data

Environment database

• AP-18253: LZ4 initialization deadlock

• AP-18232: Excel Writer fails to append to existing file using SMB Connector

• AP-18227: NPE in NodeContainerEditPart on Component Update

• AP-18216: Maximum batch size in Python is way too large

• AP-18211: XML Reader leaks input streams when using XPath with invalid reader

settings

• AP-18196: Update log4j version used by xmlbeans to 2.17.1; prevents CVE-2021-44228

and others (though not exploitable in KNIME)

• AP-18147: Excel Cell Updater in Wrong Repository Group

• AP-18140: Columnar Table Backend not part of default Mac installation

• AP-18136: SinkManager and BatchProcessors are not synchronized during Python

kernel close
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• AP-18132: Workflow Service Output doesn’t include the data of 'static inputs' when

writing Workflow Port Objects

• AP-18126: Custom/KNIME URL file system does not properly handle HTTP responses

with compressed Content-Encoding

• AP-18121: Index Reader node does not use connected file system

• AP-18107: Array flow variables are exposed as Py4J objects

• AP-18090: DB Connectors apply default value of new parameter instead of backward

compatible value when restoring existing connection

• AP-18074: Sorting tables containing DictEncoded DataCells fails in view

• AP-18069: Python Script (Labs) node converts conda environment variable to string

• AP-18067: Python Table with Void Column (all values are None) throws error

• AP-18042: Python: knio.write_table throws error, if cell type is not supported by PyArrow

• AP-17793: Displaying errors in the map view of the Open Street Map extension

• AP-17559: Excel Writer fails when writing to XLSX with Evaluate Formulas option

enabled

• AP-17541: Wait… node should not block a worker thread from the thread pool when

waiting for file

• AP-17072: Salesforce Simple Query node does not properly URLencode the where

clause

• BD-1153: (Big Data Extensions): PySpark: Invalid Python code inserted when clicking on

input column

KNIME Analytics Platform 4.5.2

Release date: March 23, 2022

New nodes

• AP-18428: Snowflake H2O MOJO Predictor (Dimension Reduction)

• AP-18427: Snowflake H2O MOJO Predictor (Autoencoder)

• AP-18400: Snowflake H2O MOJO Predictor (Isolation Forest)

• AP-18399: Snowflake H2O MOJO Predictor (Cluster Assigner)

• AP-18358: Snowflake H2O MOJO Predictor (Regression)
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• AP-18357: Snowflake H2O MOJO Predictor (Classification)

Enhancements

• AP-18486: Support advanced FTPS settings in FTP Connector

• AP-18456: Support constrained delegation in Oracle Connector node

• AP-18391: Allow to specify endpoint URL for Interactive and Username/Password

authentication in Microsoft Authentication node

• AP-18321: Default "max thread count" too small: adjust to 2x #(v)CPUs - yields higher

CPU utilization on I/O intense workflows (and reverts back to 4.4 behavior)

• AP-18305: Microsoft Authentication: Add User.Read scope to allow listing of group

membership when selecting Sharepoint group sites

• AP-18217: Support advanced Parquet settings in Snowflake DB Loader

Bug Fixes

• AP-18694: R nodes not working because of incompatible plugins after update from

4.4.x to 4.5.x

• AP-18603: Birt reporting: Palette view no longer part of default perspective (it’s hidden)

• AP-18554: NullPointerException on component update under special circumstances

• AP-18479: Composite view doesn’t load if layout references a nested component

without any view-nodes

• AP-18349: Pre-signed S3 URLs fail with Custom/KNIME URL file system

• AP-18665: Workflow Comparison fails on workflows containing

metanodes/components that pass connections through

• AP-18593: Potentially scrambled output in blob columns with old table backend when

reading from Table Reader node

• AP-18488: SharePoint Online Connector sometimes fails with NullPointerException

when writing files larger 4MB

• AP-18435: (Very) rare deadlock if multiple 'image generating' js-view nodes are run in

parallel

• AP-18419: Cannot read an Excel file from SMB when it is concurrently open in Excel

• AP-18361: BufferedRowContainer#finish does not commit the last row

• AP-18296: Memory leaks in loops with wide tables
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• AP-18280: SAP integration (Theobald) registers invalid update sites to KNIME’s update

site manager (though disabled)

• AP-18279: DynamoDB integration registers invalid update sites to KNIME’s update site

manager (though disabled)

• AP-18278: Snowflake integration registers invalid update sites to KNIME’s update site

manager (though disabled)

• AP-18268: Transfer Files (Table) cant handle two connected Filesystems

• AP-18207: Python Script (Labs): Deadlock on cancel

• AP-18198: Excel Writer Unhides Hidden Sheets

• AP-18192: CSV Reader: NPE if files in folders regex results do not exist

• AP-18141: Parallel Coordinates Plot does not Plot Curved Lines in SVG Image

• AP-17993: Python auto-completion opens in comments

• AP-17965: Transfer Files (Table) and other file handling utility nodes fail during

configure if path column does not contain metadata

• AP-17785: Interplay between selection translators and re-execution logic seems not to

work

• BD-1176: (Big Data Extensions): Code completion in PySpark nodes does not work

• BD-1155: (Big Data Extensions): DB Metadata browser on Local Big Data Environment

JDBC connection shows only objects in default schema

• NXT-896: Flow variable and port object spec changes aren’t reflected in the dialog when

opened for the second time (remote workflow editor)

• UIEXT-112: CEF: Refreshing changes character encoding

KNIME Analytics Platform 4.5.3

Release date: February 1, 2023

Enhancements

• AP-19031: JSON To XML node with option to remove invalid characters

• AP-18598: Add support for using a custom Azure AD application with the Microsoft

Authentication node

• BD-1184: Add support for H2O Sparkling Water 3.32.1.2-1-3.1

• BD-1182: Add Spark 3.1 support to Create Databricks Environment node
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• BD-1181: Add Spark 3.1 support to Create Spark Context (Livy) node

• BD-1180: Add support for Spark 3.1 to KNIME Extension for Apache Spark

Bug Fixes

• AP-19699: CVE-2022-44749: Zip Slip vulnerability when opening workflows from

untrusted sources

• AP-19650: CVE-2022-42889 - Update commons-text library to 1.10

• AP-19046: Table Reader has problems with BlobDataCells when reading multiple tables

• AP-18989: The MDF Reader feature doesn’t properly install Python

• AP-18931: R integration does not work with R 4.2.0 any more (on Ubuntu)

• AP-18911: Fixed Width File Reader: Column settings are deleted when controlling the

location via flow variable on opening the dialog

• AP-18854: Inconsistent Behaviour between Match All and Match Any when comparing

Row IDs in Joiner

• AP-18851: Parquet/ORC Writer: Mode File/Folder configuration not displayed correctly

• AP-18801: Excel Writer generates error if overwriting a sheet that is used as source in

pivot table

• AP-18797: File Download Widget: Download Link not working if Component ID is 0

• AP-18772: Call Workflow Service: Fetching Parameters fails with standard KNIME SSL

certificate in config dialog

• AP-18723: Save as workflow doesn’t show all spaces on MacOs

• AP-18689: DB Loader dialog resets compression method to default for Snowflake

• AP-18683: Writing to the root folder in SharepointOnline causes a NullPointerException

• AP-18682: HTTP(S) Connector always fails to trust bad SSL certificates

• AP-18404: Gradient Boosted Tree error: Failed: Exponential Sum is not finite

• AP-17712: Update smbj library in SMB Connector to potentially fix errors

(NullPointerException, PipeShare error) when running parallel operations against DFS

• AP-15254: Sunburst chart has error after selection, close and reopen

• UIEXT-544: Sunburst chart selection is not working
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